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CHAPTER 5 AS-i EXPERIMENTAL SETUP 
  

5.1 Introduction 

In this chapter, an experiment will be developed to illustrate the AS-i operation. We will 

see the configuration of the AS-i master and slave and how to connect the master to a 

PLC via a PROFIBUS network. 

5.2 Experiment Components 

5.2.1 The PLC Unit 

The PLC Unit shown in Figure  5-1 is responsible for the sequence of the operation. It is 

connected to the AS-i master via a PROFIBUS network. A PLC program is downloaded 

to the CPU of the PLC to execute the sequence. 

 

 

 
 

 

Figure ‎5-1 PLC UNIT 
 

  

o b e i k a n d l . c o m



CHAPTER 5 AS-I EXPERIMENT SETUP 

 44 

The PLC unit consists of the following components: 

1) A S7-300 programmable logic controller with a  CPU 313C-2DP 

2) A micro memory card (inserted in the CPU) 

3) Analogue input module  

4) Analogue output module  

5) Power supply, 24VDC, 5A 

5.2.2 AS-i Unit 

The AS-i unit shown in Figure  5-2 is responsible for the AS-i operation. It is connected to 

the controller PLC via a PROFIBUS network. It reads the input signal come from the 

field (conveyor in our experiment) and sends it to the PLC which processes the signals 

and drives the outputs and sends it to the field again via the network. 

 

 
Figure ‎5-2 AS-i unit 

 

The AS-i unit consists of some modules. Each one has its own function. In the following 

sections we will describe the functionality of each module. 

5.2.2.1 AS-i Power supply “AC‎1236‎IFM” 

AS-i power supply is an essential part of the AS-i network. It provides a regulated dc 

voltage of value 30VDC .The data and the required voltage can be transmitted via the 

same 2-wires (AS-i“+” and AS-i“-”) due to the data decoupling feature in the AS-i power 

supply. In our experiment, we use the “AC 1236”of type IFM as a power supply  [7]. It is 

shown in Figure  5-3. The AS-i power supply has the following features: 

 Input 100-240 VAC/ 1.7-0.8A   

 Output 30 VDC/ 2.8 A  
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Figure ‎5-3 AS-i Power Supply (AC 1236 IFM) 

 

5.2.2.2 AS-i‎Master‎(DP/AS−i‎Link‎Advanced) 

The DP/AS-i Link (6GK1415-2BA10) shown in Figure  5-4 is both a PROFIBUS DP 

slave and an AS-Interface master at the same time. The DP/AS-i Link Advanced connects 

the actuator-sensor interface with PROFIBUS DP. Using the DP/AS-i Link, the inputs 

and outputs of the AS-i slaves can be accessed from PROFIBUS DP. Depending on the 

slave type, binary values or analog values can be accessed  [11]. 

 

The DP/AS−i Link Advanced has the following features: 

 The DP/AS-i is an AS-Interface master (complying with the AS-Interface 

specification V3.0 according to EN 50 295) and allows transparent data access to 

the AS-Interface from PROFIBUS DP. 

 Single AS-Interface master (complying with AS-Interface specification V3.0) for 

the connection of 62 AS-Interface slaves per master and integrated analog value 

transfer 

 The complete underlying AS-i line can be configured and commissioned on an 

integrated operator display on the DP/AS–i Link (for example addressing the AS-i 

slaves, I/O test of all digital and analog slaves). 

 The DP/AS-i Link is equipped with an additional Ethernet port that allows the use 

of the integrated Web server and firmware updates. 

 Optimum TIA integration over STEP 7, linking of third-party engineering tools 

using PROFIBUS type file (GSD) 

 Power supply from the AS-Interface cable (line 1), therefore no additional power 

supply necessary, as an alternative, a 24 V DC power supply can be used. 

 Module replacement without PG by using C-PLUG (Configuration Plug)  [11]. 
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Figure ‎5-4 DP/AS−i‎Link‎Advanced 

 

5.2.2.3 AS-i‎slave‎“AC2264‎IFM” 

The AS-i slave is responsible for the interface between the field (conveyor) and the AS-i 

master. 

 
 

Figure ‎5-5 AS-i slave module (AC2264 IFM) 
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The AS-i slave module (AC2264 IFM) shown in Figure  5-5 and Figure  5-6 has the 

following features  [12]: 

 The slave profile is S-7.0.E 

 Maximum number of these slaves modules per master 62 with AS-i master v2.1 

and v3.0 

 The slave module can be connected to four digital inputs and three digital outputs. 

 The slave module can be addressed using addressing unit via addressing socket 

„ADR‟. 

 

 
 

Figure ‎5-6 Schematic Diagram of IFM AS-i slave module AC2264 

 

The following Table  5-1 contains the connection of each pin in the AS-i slave module 

AC2264. 

 

Table ‎5-1 Pin Assignment in AS-i slave module AC2264 

 

Pin Connection 

A+ AS-i + 

A- AS-i – 

I+ Sensor supply +24 V 

I- Sensor supply 

E+ Actuator supply +24 V 

E- Actuator supply 0 V 

I1 ... I4 Switching inputs sensors 1...4 

O1 ... O3 Switching outputs actuators 1...3 

O- Switching output actuator 0 V 
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The AS-i slave module AC2264 has three groups of LEDs, each group has its 

functionality:   

 LEDs 1: indicate the switching status of sensor inputs 

 LEDs 2: indicate the AS-i network, AS-i „FAULT‟,AS-i auxiliary power „AUX‟ 

 LEDs 3: indicate the switching status of the actuator outputs. 

 

To check the safe functioning of the AS-i slave module, we have to supervise the color of 

the LEDs, as there are four different modes of status indicated by the LED color:  

 Green: voltage supply via the AS-i network is O.K. 

 Yellow: input / output signal is switched 

 Red: AS-i communication error, e. g. slave address 0. 

 Red flashing: periphery fault, e.g. no sensor supply/overload or short circuit of the 

output. 

5.2.2.4 Power supply 

A conventional power supply with, 24VDC, 5A is used to power the AS-i master, the 

sensors and actuators signals. A PHOENIX power supply shown in Figure  5-7 is used in 

our experiment with the following specifications: 

 Input 100-240 VAC/ 1.9-0.9A 50-60 Hz 

 Output 24 VDC/ 5 A  

 

 
 

Figure ‎5-7 PHOENIX Power Supply 

 

5.2.2.5 AS-i cable 

Yellow AS-i cable is used for communication between the AS-i slave and the AS-i 

master. An additional black cable is used for conventional power transfer 24 VDC. 

Figure  5-8 shows the different types of AS-i cables used in the experiment. 
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Figure ‎5-8 AS-i Cable 
 

5.2.2.6 Accessories 

Some other components are used in the AS-i unit, it can be concluded in the following 

Table  5-2: 

 

Table ‎5-2 Accessories in AS-i unit 

 

Item Component Qty 

1 2 fuse ,Neon switch inlet 1 

2 Power cable 1 

3 UM 45-D25SUBIB 25pin female connector 1 

4 UM 45-D25 SUBIS 25pin male connector 1 

5 DUCT (Trunk ) (4X4 ) 3 

6 Omega 2 

7 Rosette with fuse 4 

8 Rosette without fuse 4 

9 Rosette earth 2 

10 25pin male-female cable 2 

11 Wires (Blue, Brown, Yellow x Green) 1.5 mm 5m 

12 Wires (Blue, Red, Black) 0.5 mm 5m 

 

5.2.2.7 AS-i unit wiring  

 

Figure  5-9, Figure  5-10, Figure  5-11, Figure  5-12 and Figure  5-13 illustrate the AS-i unit 

wiring. 
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Figure ‎5-9 Source of 220 VAC 

 

 
 

Figure ‎5-10 Source of 24 VDC 
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Figure ‎5-11 AS-i power supply wiring 

 

 

 

Figure ‎5-12 DP/AS−i‎Link‎wiring 
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Figure ‎5-13 AS−i‎Slave‎Module‎wiring 

 

5.2.3 Field‎Application‎“Conveyor” 

A conveyor unit is used for simulation of package transfer line with some pushbuttons 

and photo cells fixed on it to control its operation. 

 

 
 

Figure ‎5-14 The Conveyor Unit 
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The conveyor unit shown in Figure  5-14 has 8 inputs which are  four switches 

(S1,S2,S3,S4) and four photocells (PH1,PH2,PH3,PH4) and has five outputs which are 

four LEDs (H1,H2,H3,H4) and belt run ,each one of these signals has a unique address 

which will be assigned in the experiment. 

 

5.3 Experiment Steps 

5.3.1 PLC Project 

A PLC project should be applied to operate the sequence of the application, as the PLC 

used in the application is of type SIEMENS, we will use the SIMATIC Manager to 

develop the PLC code and to configure the AS-i master. The SIMATIC Manager is a 

graphic user-interface for online/offline editing of S7 objects (projects, user program 

files, blocks, hardware stations and tools)  [13]. The project creation should be done in a 

sequence illustrated in the following steps. 

1. Starting the SIMATIC Manager 

After installation, there is a "SIMATIC Manager" icon on the Windows desktop. You 

activate the program just like all other Windows applications when you double-click the 

icon     as shown in Figure  5-15. 

 

 
 

Figure ‎5-15 Starting SIMATIC Manager 

 

With the SIMATIC Manager you can: 

 Manage projects and libraries. 

 Activate STEP 7 tools. 

 Access the PLC online. 

 Edit memory cards. 
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2. Creating S7 project 

To create a S7 project you should select the menu options File -> New or the symbol 

from the toolbar to open the "New" dialog box for creating a new project or a new 

library. Enter the project name in the "Name" box and click the "OK" button to 

confirm as shown in Figure  5-16. 

 
 

Figure ‎5-16 Creating S7 project 

3. Inserting S7 program 

To insert a S7 project you should: Select the Insert -> Program -> S7 Program menu to insert a new 

program into the current project as shown in  

Figure  5-17. When you insert an object, the system automatically gives it a relevant 

name, such as "S7 Program (1)". You can then change this name if you like. 

 

 
 

Figure ‎5-17 Inserting S7 program 
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4. Hardware Configuration and parameters assignment 

With the Hardware Configuration tool you can: 

 Assign racks, blocks and I/O modules by selecting them from hardware catalogue. 

 Modify preset parameters or addresses of a module. 

 Configure communication connections with stations that have distributed 

peripherals (PROFIBUS-DP). 

 

The following sequence illustrates the steps to create a hardware configuration properly: 

Step 1: Inserting a Station 

To call the “HW Config” tool, there must be a hardware station in the SIMATIC 

Manager. As shown in Figure  5-18: you insert a new station in the current project by 

selecting the menu options Insert -> Station -> SIMATIC 300 Station  [14]. 

 

 
Figure ‎5-18 Inserting a Station 

Step 2: Starting Hardware Configuration editor 

As shown in Figure  5-19 to start the "HW Config" editor you should select a hardware 

station in the SIMATIC Manager and choose the Edit --> Open Object menu or double 

click the hardware object  icon. To open the hardware catalog you should select the 

View -> Catalog menu or click the   icon in the toolbar. If “Standard” is selected as 

the catalog profile, all racks, modules and interface modules are available in the 

"Hardware Catalog" window.  
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Figure ‎5-19 Hardware Configuration tool 

Step 3: Rack select  

To insert a rack, you have to open a SIMATIC300 station in the Hardware Catalog. 

Opening the "RACK-300" folder shows the icon for a DIN rail. You can insert this in the 

"Hardware Configuration" window by double-clicking on it (or using drag & drop). Two 

rack components list then appear in the two-part window: a plain list in the top part and a 

detailed view with order numbers, MPI addresses and I/O addresses in the bottom part. 

Step 4: CPU select 

As shown in Figure  5-20 you select the CPU from the "CPU-300" folder, and insert it in 

slot no. 2. 

Step 5: Establish PROFIBUS network 

As shown in Figure  5-21 to establish the PROFIBUS network, we have to proceed as 

follows: 

1) Double click on the DP property of the CPU, the window “Properties –DP“ 

appears. 

2) Click the properties button in the window, the window “Properties –PROFIBUS 

interface DP“ appears. 

 

o b e i k a n d l . c o m



CHAPTER 5 AS-I EXPERIMENT SETUP 

 57 

 
Figure ‎5-20 CPU Selection in H.W Configuration Tool 

 

3) Click new in the window to create a new network and assign a unique address for 

the CPU in the PROFIBUS network and select the transmission rate. In this 

example the address of the CPU in the PROFIBUS network is “2“, and the 

transmission rate is 1.5 Mb/s.   

 

 
Figure ‎5-21 Establish a PROFIBUS network 
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4) Acknowledge the settings with "O.K.". The following symbol appears: 

for the DP master system. This symbol is used as a “hanger" for the 

DP slaves. By these steps the CPU is configured as a DP master in the network as 

shown in Figure  5-22. 

 

 

Figure ‎5-22 CPU as a DP master in the network 

Step 6: Assign the AS-i master to the PROFIBUS network 

As shown in Figure  5-23 from the PROFIBUS DP category, you select the DP/AS-i Link 

module; drag and drop it on the symbol  to assign it in the PROFIBUS 

network. 

 

 

Figure ‎5-23 AS-i master in the PROFIBUS network 
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By double click on the DP/AS-i Link module, a window “DP slave properties” appears. 

We can assign the address for it in the PROFIBUS network from the “PROFIBUS“ 

button as shown in Figure  5-24. 

 

 
 

Figure ‎5-24 Assignment an address for the AS-i master in the PROFIBUS network 

 

Step 7: Assign the I/O area of the AS-i master 

Each DP slave must reserve an area in the I/O area of the DP master “CPU in our 

example”, the I/O area reserved depend on the type of the DP slave. The DP/AS-i Link 

can reserve maximum 32 bytes in the input area and 32 bytes in the output area, as it can 

connect with 62 slaves each one is 4I / 4O. As shown in Figure  5-25 we can select the 

starting address for the AS-i master from the window “Properties-DP/AS-i 1M”. 

 

Step 8: Select the AS-i slave 

As shown in Figure  5-26 you select the AS-i slave form the drop down menu of the AS-i 

master, once you select the AS-i module all the available slots are highlighted green, you 

can select any slot to put the AS-i slave in it, each slot is reserved to a specified address 

from (1A to 31A) and form (1B to 31B), so the maximum no of slaves that can be 

connected to the master in our example is 62 slaves. 

  

o b e i k a n d l . c o m



CHAPTER 5 AS-I EXPERIMENT SETUP 

 60 

 

Figure ‎5-25 Assign the I/O area of the AS-i master 

 

 
 

Figure ‎5-26 AS-i slave module selection 

 

Step 9: Configuration of AS-i slave 

The configuration of the AS-i module consists of module type selection, I/O 

configuration code, ID code and address assignment. You can configure the AS-i slave 

from the window “AS-i slave Properties” as shown in Figure  5-27. 
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 Figure ‎5-27 AS-i slave Properties Window 

 

 From the “Module” drop-down list box you can select the type of your AS-i 

module if it is universal modules or Siemens modules based on the order number. 

 The “Selection” button opens the tree structure of the AS-Interface catalog where 

you can select the required AS-i module just as in the hardware catalog. 

 In the “Parameters” group box you can set the startup parameters 

 Using check boxes if you have selected universal modules. 

 In plain language if you have selected Siemens modules, no need to assign the I/O 

configuration code, or the ID code. Both codes are assigned automatically  

 In the “Digital Addresses” group box, you can edit the proposed digital address 

entries. This also applies to the “Analog addresses” group box, if an analog slave 

is detected  [11]. 

 

 

You have to configure the AS-i module with the parameters as they are mentioned in its 

data sheet. The I/O configuration code defines its inputs and outputs and ID configuration 

code define the profile of this slave. After finishing the configuration of the AS-i slave, 

we are ready to download the “Final Hardware Configuration” as shown in Figure  5-28. 
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Figure ‎5-28 Final Hardware Configurations 

Step 10: Saving Final H.W Configuration and downloading it to the CPU    

When you select the Station->Save and Compile menu or click the icon in the toolbar 

as shown in Figure  5-29 the configuration and parameter assignment data are also saved 

in system data blocks. The system data blocks (SDBs) are generated and modified when 

you configure the hardware and compile the hardware configuration. SDBs contain 

configuration data and module parameters  [13]. To download the selected configuration 

to the PLC: choose the PLC -> Download menu or click the  icon in the toolbar as 

shown in Figure  5-30. 

 

 
  

 Figure ‎5-29 Saving Final H.W Configuration 
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Figure ‎5-30 Downloading Final H.W Configuration to the PLC 

5. I/O Symbol Assignment 

Every "S7 program" has its own symbol table. You can open a symbol table from the 

SIMATIC Manager with a double click on the "Symbols" icon as shown in Figure  5-31. 

 

 

Figure ‎5-31 Symbol Table in S7 Program 

 

In the symbol table (refer to Table  5-3), a line is created for every variable. You can then 

enter the symbol name, the address, the data type and a comment for the variable in the 

columns. A blank line is automatically added at the end of the table for defining a new 
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symbol  [14]. The following table illustrates the input- output symbols used in the S7 

program. 

 

Table ‎5-3 I/O symbols used in the S7 program 

 

Symbol Address Data Type 

CONVEYOR PHOTO CELL(PH4) I      32.0 BOOL 

MOTOR START(S1) I      32.1 BOOL 

MOTOR STOP(S2) I      32.2 BOOL 

MOTOR RUN Q      32.0 BOOL 

INDICATION LAMP RUN(H1) Q      32.1 BOOL 

INDICATION LAMP STOP(H2) Q      32.2 BOOL 

6. PLC Code 

The tool LAD/STL/FBD Editor is used to edit the PLC code; you can open it by double 

clicking on the block organization block number one (OB1). This block contains the code 

divided into separate networks using a LAD programming language as shown in 

Figure  5-32. After finishing the programming phase, we have to save the block (OB1) 

and download it on the PLC by clicking the  icon or selecting the PLC -> Download 

menu option 

 

 

Figure ‎5-32 Code in LAD 
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5.3.2 Commissioning the DP/AS-i  Link 

The following steps illustrate the commissioning of a DP/AS−i Link  [11]: 

 

1) Install the DP/AS−i Link and connect it to the AS-i cable. 

2) Connect the AS-i power supply unit to the AS-i cable. 

3) Turn on the AS-i power supply unit to start up the DP/AS−i Link. 

4) Connect the AS-i slave to the AS-i cable and assign the required slave address. 

→SYSTEM AS-i line 1 Life list  Change Address Change Slave 

Address. 

5) Adopt the actual configuration of the slaves as the desired configuration on the 

DP/AS−i Link. 

→SYSTEM AS-i line 1 Life list  Act −> Conf Adopt Act −> 

Conf Result: All the LEDs for the AS-i line on the DP/AS−i Link are off or green; 

in other words, the slave has been included successfully. 

6) Assign the PROFIBUS address for the DP/AS−i Link (the address must match the 

settings made above in the H.W configuration tool.) 

→SYSTEM PROFIBUS Info DP Address  Change Address. 

7) Connect the DP/AS−i Link to the PLC over the PROFIBUS cable. 

5.4 Experiment Operation 

The following steps illustrate the experiment Operation: 

 

1) Connect the conveyer to the AS-i unit with the two 25 pin male-female cables. 

2) Power on the PLC unit and the AS-i unit. 

3) Check that the „Run‟ led on the CPU and the AS-i master led „ON‟ are on. 

4) Check that the LEDs System Fault „SF‟ and Bus Fault „BF‟ are off on the CPU 

and the AS-i master. 

5) Put the block on the conveyor.  

6) Press the button motor start (S1). 

7) The conveyor starts to move in right direction and the indication led (H1) is on. 

8) When the block becomes in front of the photocell at the conveyor end, the 

conveyor stops, the indication led (H1) is off and the indication led (H2) is on. 

9) You can also stop the conveyor by pressing the button motor stop (S2). 

5.5 Summary 

One of the most important characteristic of the AS-Interface technology is the use of a 

common two-core cable for data transmission and distribution of auxiliary power to the 

sensors and actuators. The DP/AS-Interface Link is a single master gateway, which can 

access inputs and outputs of the AS-Interface slaves and communicate to the PLC via 

PROFIBUS network. The SIMATIC Manager S7 is used to configure the DP/AS-

Interface Link, assign parameters to the AS-i slaves as well as program the PLC with 

operation code. 
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